FC-Cheats

From pressy's brainbackup
Jump to: navigation, search

FC-Cheats

# cfgadm -o show_FCP_dev -al 
Ap_Id				Type		Receptacle	Occupant		Condition
c5				fc-fabric	connected	unconfigured		unknown
c5::200600a0b8170fb2	disk		connected	unconfigured		unknow

This should map to /etc/cfg/fp/fabric_WWN_map Same to:

# luxadm -e port
/devices/pci@1f,4000/SUNW,qlc@2/fp@0,0:devctl              CONNECTED

# luxadm -e dump_map /devices/pci@1f,4000/SUNW,qlc@2/fp@0,0:devctl
Pos  Port_ID Hard_Addr Port WWN         Node WWN         Type
0    140200  0         200600a0b8170fb2 200600a0b8170fb1 0x0  (Disk device)
1    140500  0         210000e08b0a62e0 200000e08b0a62e0 0x1f (Unknown Type,Host Bus Adapter)
# cfgadm -al -o show_SCSI_LUN <controller_id>
# cfgadm -al -o show_FCP_dev <controller_id>


If Fabric-attached devices are not present or turned off, boot errors will occur. Without corrective action, these errors will persist for every reboot. The boot errors which are linked to this problem, can be found in the /var/adm/messages file, and are formatted as follows: luxadm[90]: [ID 593423 user.error] ID[luxadm.create_fabric_device.2316] configuration failed for line (/devices/pci@8,600000/SUNW,qlc@2,1/fp@0,0:fc::256000c0ffc028e4) in file: /etc/cfg/fp/fabric_WWN_map. I/O error scsi: [ID 243001 kern.warning] WARNING: /pci@8,600000/SUNW,qlc@2,1/fp@0,0 (fcp4): Failed to create nodes for pwwn=266000c0ffe028e4; error=5

The reason for these errors is that the device in question is no longer present on the Sun StorEdge[TM] SAN. If that device has been removed (or moved), Solaris[TM] Operating System(OS) will continue to report this error, every time it boots, until corrective action is taken.

Resolution: If device has been moved or removed Execute the command:

# cfgadm -o force_update -c unconfigure <c#::wwn>

where <c#::wwn> represents the controller number and World Wide Number(WWN) of the device that has been removed. To list all the Fabric devices that should be configured, use the command:

# cfgadm -la

The "c#" can also be found in /dev/cfg by doing ls -l on the physical path listed in the error message. In the above example, the designation would be "c3::256000c0ffc028e4". To avoid this problem in the future, use the following command before removing the device from the Storage Area Network(SAN):

# cfgadm -c unconfigure <c#::wwn>

If no device has been moved or removed: forceloading the following drivers during the boot process in /etc/system can resolve the issue.

forceload: drv/qlc
forceload: drv/fctl
forceload: drv/fcp
forceload: drv/fp

If the following drivers are being used by the system it would be worth forceloading these as well.

forceload: drv/ssd
forceload: drv/scsi_vhci

Note: If problem persists, this error is due to a different problem, and further investigation is required.

Unconfigure LUN

Example:

# cfgadm -o show_FCP_dev -al
Ap_Id                          Type         Receptacle   Occupant     Condition
c4                             fc-fabric    connected    configured   unknown
c4::500104f0008ad6a2,0         tape         connected    configured   unknown
c4::500104f0008ad6b1,0         tape         connected    configured   unknown
c4::500104f0008ad6ba,0         tape         connected    configured   unknown
c4::500104f0008ad6c6,0         tape         connected    configured   unknown
c4::50060e80042a8762,0         disk         connected    configured   unknown
c4::50060e80042a8762,1         disk         connected    configured   unknown
c4::50060e80042a8762,2         disk         connected    configured   unknown
c4::50060e80042a8762,3         disk         connected    configured   unknown
c4::50060e80042a8762,4         disk         connected    configured   unknown
c4::50060e80042a8762,5         disk         connected    configured   unknown
c4::50060e80042a8762,6         disk         connected    configured   unknown
c4::50060e80042a8762,7         disk         connected    configured   unknown
c4::50060e80042a8762,8         disk         connected    configured   unknown
c4::50060e80042a8762,9         disk         connected    configured   unusable
# cfgadm -o unusable_FCP_dev -c unconfigure c4::50060e80042a8762

LUN failed to configure

# cfgadm -c configure c3
cfgadm: Library error: report LUNs failed: 50060e801530fb39
Operation partially successful. Some failures seen
# cfgadm -o force_update -c configure c3::50060e801530fb39
cfgadm: Insufficient condition
root@server # luxadm -e port
/devices/pci@3,0/pci1022,7458@9/pci1077,149@1/fp@0,0:devctl        CONNECTED
/devices/pci@3,0/pci1022,7458@a/pci10df,fc00@1/fp@0,0:devctl       CONNECTED
/devices/pci@3,0/pci1022,7458@a/pci10df,fc00@1,1/fp@0,0:devctl     CONNECTED
# luxadm -e forcelip /devices/pci@3,0/pci1022,7458@9/pci1077,149@1/fp@0,0:devctl

Wait some seconds for the next controller, until you see in your messages:

emlxs: [ID 349649 kern.info] [ 5.05F8]emlxs0: NOTICE: 730: Link reset.
emlxs: [ID 349649 kern.info] [ 5.0337]emlxs0: NOTICE: 710: Link down.
emlxs: [ID 349649 kern.info] [ 5.054D]emlxs0: NOTICE: 720: Link up. (2Gb, fabric, initiator)

ALUA and MPxIO

see: NetAPP_vs._MPxIO